1.png P-G-B-Fusion Powered by PHP-Fusion Inc 2.png
Heute ist Mittwoch der 29.Mai 2024 es ist ZeitUhr
Navigation
sideb-left.pngsideb-right.png
Online Information
sideb-left.pngsideb-right.png
Foren Themen
Neueste Themen
bullet.gif Ratingsystem install...
bullet.gif Die Regeln im Forum!
Heißeste Themen
Keine Themen erstellt
sideb-left.pngsideb-right.png
Discord
sideb-left.pngsideb-right.png
Partner

Serverüberwachung / Servermonitoring mit Livewatch.de
Servermonitoring mit Livewatch.de




Text-Überwachung und Plagiatsprüfung durch PlagAware

..::www.DeeoNe.de-D1Infusionen::..
sideb-left.pngsideb-right.png
System Info
IP

Diese Seite läuft auf:
PHP-Fusion v7.02.07
mit
PHP 7.4.33
sideb-left.pngsideb-right.png
js-controller 5.0.x jetzt für alle User im STABLE!

Informationen zur Version
Es gibt EINIGE Adapter die aktualisiert werden müssen!! Bitte weiter unten lesen!

In dieser Version wurde die Umstellung des Quellcodes auf TypeScript sehr stark vorangetrieben (inzwischen bei 88%), wodurch am Ende die Stabilität weiter steigt weil viele Code-Fehler nicht mehr auftreten können. Natürlich sind neben Optimierungen und Fehlerbehebungen auch ein paar neue Features hinzugekommen. Auch wenn mit dieser Version keine neuen Prüfungen hinzukommen, die zu Log-Ausgaben bei Adaptern führen, meldet aktuelle Logausgaben bitte weiterhin bei den Adaptern.

Detailliertere Informationen zu allen Änderungen und Features findet Ihr weiter unten und im Changelog.

Für die aktive Mitarbeit an dieser Version des js-controller bedanke mich diesmal wieder besonders bei Apollon77, AlCalzone und natürlich Bluefox und auch ein paar weiteren Entwicklern!

ACHTUNG backups inkompatibel bei Downgrades!!

Neben der Node.js Version gibt es eine wichtige Inkompatibilität: Backups die mit der 5.0 des js-controller erstellt wurden lassen sich nicht mit einem js-controller 4 oder kleiner wieder restoren!

Darüber hinaus ist der js-controller 5.0 generell kompatibel mit allen bestehenden ioBroker-Systemen. Ein Update von der 2.0/2.1/2.2/3.x ist problemlos möglich. Wir empfehlen allerings vor dem Update auf die 5.0 idealerweise ein Update auf die 4.0 und vorher auf 3.3.x durchzuführen, da ein Downgrade nach einem erfolgten Update nur auf eine 3.3.x möglich ist (siehe FAQ)! Nur die Node.js Version muss weiterhin mindestens 16.x sein, wie oben bereits ausgeführt. Wer überlegt die Node.js Version anzuheben bitte weiter unten im Abschnitt "Was ist zu testen" lesen 

Aufgrund einiger internen Umstellungen brauchen wieder einige Adapter Updates. Diese sollten am besten VOR dem Update installiert werden!
Bitte dazu die Informationen weiter unten beachten!

Installation


VOR der Installation

Wie bei jedem Upgrade dieser Art: Bitte macht ein Backup! iobroker backup bzw kopieren des iobroker-data Verzeichnisses reichen an sich aus. Bitte nicht das node_modules Verzeichnis einfach kopieren, da sonst symbolische Links kaputt gehen können, was zu größeren Problemen danach führt. Eine alte 4.0.x-Version des js-controller kann im Notfall einfach wieder per npm install iobroker.js-controller@version ("version" durch die gewünschte Versionsnummer ersetzen) installiert werden und sollte alles wieder herstellen (Vorheriger Stable Stand ist die 4.0.24)

Nötige Adapter-Aktualisierungen

Am besten dennoch VOR dem js-controller Update alle verfügbaren Adapter-Updates prüfen und alle Updates installieren, die im Changelog auf Optimierungen oder Anpassungen für den js-controller 4.0 oder höher hinweisen.

Diesmal sind doch einige Adapter auf der Liste die man updaten muss -falls installiert! Siehe Spoiler!

Was hat sich geändert, was besonders ansehen/beachten?


Neben einiger weiterer Bugfixes gibt es folgende Änderungen und Fixes zu erwähnen:

  • generell siehe Changelog, speziell auch für die Features
  • generell bitte im CLI und auch sonst überall drüber schauen. Die Typescript Umstellungen haben sehr viel Code angefasst.
  • Falls jemand sporadisch Alias Fehler im Log hatte bitte versuchen diese mit der neuen version wieder zu provoziere und rückmelden

Speziell die Entwickler sollten bitte die genannten Deprecations und neuen Features anschauen und beachten.

 

Quelle/Nachlesen: Nachlesen

 

centerb-left.pngcenterb-right.png
Kommentare
#1 | matze , 04. Oktober 2023 um 22:32:09
Sollte man auch tun......da auf Proxmox auch Prob gab bei mir

Node JS schon lange aktuell

Alle Adapter stopen.......so habe ich es getan......Java über die Shelly Konsole upgraden.....pakete eh.....Node Js auch per Shelly....dann Adapter neu starten

Aber unter Host im adminbereich sollte es eigentlich angezeigt haben....

Github hilft viel

lg
centerb-left.pngcenterb-right.png
Kommentar schreiben
Bitte logge dich ein, um einen Kommentar zu verfassen.
centerb-left.pngcenterb-right.png
Bewertungen
Bitte logge dich ein, um eine Bewertung abzugeben.

Es wurden noch keine Bewertungen abgegeben.
centerb-left.pngcenterb-right.png
Anmelden



Registrieren Passwort vergessen
sideb-left.pngsideb-right.png

Umfrage
Zur Zeit gibt es keine Umfrage.
sideb-left.pngsideb-right.png
Shoutbox
Du musst eingeloggt sein um eine Nachricht zu schreiben.

matze
matze
aus Hettstedt
29.01.2024 um 21:46
Offline
Gruss an die Allgemeinheit... good job

matze
matze
aus Hettstedt
14.04.2023 um 01:02
Offline
Na mal sehen ob es bald ,,wärmer ,, wird

Esox
Esox
aus Berlin
22.02.2023 um 16:56
Offline
Hurraaaaa, Karneval ist vorbei good job


Shoutbox Beiträge: 22
sideb-left.pngsideb-right.png
ScoreSystem
Platz Name Euronen
1. Esox 104712
2. matze 4641
3. partybremen 1676
4. Ernst74 1422
5. Tester 331
sideb-left.pngsideb-right.png